Welcome Guest [Log In] [Register]
cheapivecoparts.co.uk

These forums are free and rely upon the goodwill of members to help and assist others. Any donations will be gratefully received.

You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are some features you can't use.

Join our community!

If you're already a member please log in to your account to access all of our features:

Username:   Password:
Add Reply
Daily no start-warning lights on.
Topic Started: Oct 4 2017, 09:15 PM (126 Views)
PhilipK
No Avatar
Newbie
[ * ]
Hi, i'm having problems with a Daily, it does not start, starter swings engine but nothing else.
The icon (yellow padlock) on the instrument cluster stays on, this indicates that the system does not recognise the key, I tried the spare key without any success. In the manual there is a procedure to follow to start the vehicle by entering the electronic code if the system does not recognise the key, you are suppose to use the accelerator pedal while watching the EDC light flashing, I am unable to do this as the EDC light stays on and does not flash.

It seems that the computer thinks the engine is running because on the display it gives the following warnings: Check engine- excessive radiator fluid temp-stop engine-abs not available. That while the engine is stone cold and not running, obviously not running because it cannot start! Something else that is strange is that when the ignition is switched on the oil warning light lights up but then goes out as if the engine started!
Is there anybody with some advice as to what the possible problem could be? Any info or tips would be welcome, thank you.
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
« Previous Topic · Iveco Daily 2014 > Present · Next Topic »
Add Reply

These forums are free and rely upon the goodwill of members to help and assist others. Any donations will be gratefully received.