Welcome Guest [Log In] [Register]
cheapivecoparts.co.uk

These forums are free and rely upon the goodwill of members to help and assist others. Any donations will be gratefully received.

You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are some features you can't use.

Join our community!

If you're already a member please log in to your account to access all of our features:

Username:   Password:
Add Reply
Blue smoke
Topic Started: Oct 12 2017, 06:33 PM (48 Views)
monty400k
No Avatar
Member
[ *  * ]
Just replaced my 07 Daily with an 11 35c18, high miles at 240k but in great condition and drives like new, however its burning oil if left to idle at lights etc, clouds of blue smoke when I pull away which clear quite quickly, I assume valve stem oil seals. Spoke to my mechanic who knows these quite well, he was surprised even at this mileage, he suggested a service to make sure there was fresh oil in there, Id say its made a bit of difference but not cured it. He explained that the head will have to come off to stop the valves dropping into the cylinders, pita but probably worth doing, assuming there isn't anything else that I should check first, really does drive well, came with a dealer service history up until last year so its clearly been looked after. Thanks
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
« Previous Topic · Iveco Daily 2006-2014 (previously 4th & 5th gen forums) · Next Topic »
Add Reply

These forums are free and rely upon the goodwill of members to help and assist others. Any donations will be gratefully received.