Welcome Guest [Log In] [Register]
cheapivecoparts.co.uk

These forums are free and rely upon the goodwill of members to help and assist others. Any donations will be gratefully received.

You're currently viewing our forum as a guest. This means you are limited to certain areas of the board and there are some features you can't use.

Join our community!

If you're already a member please log in to your account to access all of our features:

Username:   Password:
Add Reply
Engine troubles 35c18; Engine runs like there is air in fuelline
Topic Started: Sep 16 2013, 06:46 AM (1,760 Views)
alex bj
No Avatar
Newbie
[ * ]
Hello

I havent put the car to iveco yet and hope to get and usefull solution in here..
The problem comes and goes..
Edc light flash and some times stay on,this normally happends in the speed area 80-100 with load on,sometimes the yellow engine light comes on and stay turned on..
When the car is shut down all errors are away..
What happends is that the car when it drives runs like it has air in fuel,you need to press the speeder down to the bottom before you get power,if the speedpilot is on it will go in off mode.
It all starts with flashing edc light.
If you shutdown the engine and try to start directly after the problem,the engine will only run at idle speed,even if you press the speeder down to bottom.
Last time when i drove i noticed the speedometer goes backwards..
Fuelfilter is new and original part and all service has been followed
Car has done 110000 km
Any solutions?

Regards alex
Edited by alex bj, Sep 16 2013, 06:47 AM.
Offline Profile Quote Post Goto Top
 
Bazil-S
Member Avatar
Member
[ *  * ]
Hi,

Never say, "I replaced the fuel filter" in the singular. Daily has two fuel filters, the first is a pre-filter located on the chassis under vehicle and the second is the main filter placed under bonnet.
The pre-filter is more exposed to clogging and is often forgotten.
Should not be neglect the air supply system, so you can begin to check the integrity of the air hoses and the intercooler. Remove the input hose from intercooler and try to suffocate the engine by obturating the intercooler input, with your hand. The engine must stop, if not, it means there is a crack somewhere.
Check the thin vacuum hoses, starting from servo brake to VGT and EGR actuators.
Also read these topics:

http://ivecoforums.com/topic/8823623/1/#new

http://ivecoforums.com/topic/8879600/1/#new
Offline Profile Quote Post Goto Top
 
Sudesh
Member Avatar
35s18
[ *  * ]
Bazil-S
Sep 16 2013, 08:55 PM
Hi,

Never say, "I replaced the fuel filter" in the singular. Daily has two fuel filters, the first is a pre-filter located on the chassis under vehicle and the second is the main filter placed under bonnet.
The pre-filter is more exposed to clogging and is often forgotten.
Should not be neglect the air supply system, so you can begin to check the integrity of the air hoses and the intercooler. Remove the input hose from intercooler and try to suffocate the engine by obturating the intercooler input, with your hand. The engine must stop, if not, it means there is a crack somewhere.
Check the thin vacuum hoses, starting from servo brake to VGT and EGR actuators.
Also read these topics:

http://ivecoforums.com/topic/8823623/1/#new

http://ivecoforums.com/topic/8879600/1/#new
Hi Bazil,

Do all Dailys have the "pre-filter"?

I assume its close to te fuel tank somewhere?
Offline Profile Quote Post Goto Top
 
Bazil-S
Member Avatar
Member
[ *  * ]
Hi,

My apologies, it is my mistake... I was convinced that I post in the third generation section. Daily fourth generation (Euro 4) usualy do not have pre-filter on the chassis. Although there are models that have electric pump on the chassis and pre-filter. These models are manufactured for extra European market, or on request.
Once again I apologize!
Regards.

Bazil-S
Edited by Bazil-S, Sep 19 2013, 03:44 PM.
Offline Profile Quote Post Goto Top
 
alex bj
No Avatar
Newbie
[ * ]
Thanks for input,the car is european(dk) i was also told that there was another filter located under car somewhere..
Today another problem started,my glowplug light flash after start?
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
« Previous Topic · Iveco Daily 2006-2014 (previously 4th & 5th gen forums) · Next Topic »
Add Reply

These forums are free and rely upon the goodwill of members to help and assist others. Any donations will be gratefully received.